提供zblog模板_zblog主题_wordpress模板的下载和定制

vue3项目引入vant报错的错误原因和解决办法

天兴工作室 2024-03-12 14:57 教程 350 0 评论


最近在折腾一个vue3项目,本来是一个简单的单页面,一些常用组件都自己随便写了,结果功能越搞越多折腾到后面已经头疼了。于是及时删掉自己写的辣鸡,直接引进vant这个ui框架。

结果按照官方文档安装好vant后在页面引入发现直接报错了,vant引入代码如下:

vue3项目引入vant报错的错误原因和解决办法 vant npm vue3 教程 第1张

错误代码如下

vue3项目引入vant报错的错误原因和解决办法 vant npm vue3 教程 第2张

这个报错就很奇怪了,\.vite\deps里面不应该是自动写入依赖的组件信息么?我翻看了这个文件夹确实没找到对应的文件。

于是按照关键词在网络上搜索,都没有找到解决方案。

最后换了多个关键词终于让我搜到了一篇文章,这篇文章给了一个解决方案,说可能是npm版本问题,原文如下:

在开发过程中Vue3的依赖版本有变更,直接使用的npm install下载新的版本,会导致node_modules下存在旧版本的缓存,从而影响了本地项目的启动编译。

然后我尝试先删掉“node_modules”文件夹,重新“npm install”之后问题解决了!


如果你也遇到了同样的问题,也可以先做好备份然后重装npm试试。


没有找到能解决你问题的教程?

您可以试着搜索一下或者直接在线提问。我们也提供收费技术支持,有需要可以在线联系我们。

在线提问 在线客服

欢迎 发表评论: 取消回复

请填写验证码
  • 最新文章
  • 热文排行
  • 最多评论
标签聚合
  • 登 录
  • 注册账号 忘记密码?
  • 注 册
  • 已有账号?直接登录 忘记密码?
  • 社交账号登录